Broadband outages in and around London (Southbank)
Incident Report for Voipfone
Resolved
Issue has now been resolved
Posted 3 months ago. Sep 26, 2018 - 13:23 BST
Identified
The issue has been identified within the BT network, BT are working on corrective actions.
Posted 3 months ago. Sep 26, 2018 - 12:22 BST
Investigating
A number of connections in and around London have lost connectivity due to a BT outage, BT are currently investigating.
Posted 3 months ago. Sep 26, 2018 - 12:11 BST
This incident affected: Broadband.