Inbound Calls to International Numbers

Incident Report for Voipfone

Resolved

This incident is now resolved.

Again, our apologies for any inconvenience caused.
Posted May 19, 2025 - 15:32 BST

Monitoring

Service has been restored to the affected international numbers, the issue was caused by routing changes in an upstream carrier network. Please contact us if you believe any of your numbers are still affected.

Our apologies for any inconvenience this may have caused.
Posted May 19, 2025 - 13:49 BST

Investigating

We are currently investigating reports of failures to a subset of our international numbers.
Posted May 16, 2025 - 17:46 BST
This incident affected: Voice Services (Inbound Calls to International Numbers).